Jump to content
Sign in to follow this  
Alex

Test Server Bugs - REPORT HERE

Recommended Posts

I seem to have encountered an issue. I created a nation of the Test Server on the first of the month and encountered issues with 0 cities and what not. Well when I returned to the Test Server to check up on my nation, I was unable to log in. Tried a few attempts and couldn't get in so I chalked it up to Test Server weirdness.

Well today, I tried to log in and it made me a new account only that when I went to re-found my nation (under the assumption it had been removed for some reason) that Velorum (my nation) already existed. I have no option to access to a nation screen despite using the same account from when I signed up originally and when I try to create a nation it says my nation already exists. I know it isn't someone elseĀ because I made it the first time around.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and the Guidelines of the game and community.