Jump to content

Recommended Posts

What were you doing (or trying to do): Attck a nation on test after declaring

What happened (describe thoroughly please): While testing out various aspects of the game I came across a peculiar issue after declaring on one specific nation. I would go to issue an attack (whether it was ground, air or naval, the same things happened) the attack proceeded as normal but when I clicked go back to war page after a successful attack, no maps had been spent, no military unites used up and resistance remained the same. After ruling out that it was the computer I was on, the browser (firefox initially) I was using, any browser add-ons, my vpn ect I logged off, then back on again, issue persisted. I logged off, rebooted my pc logged back on and issue persisted. I tried using different browsers, chrome, and chronium) I tried using a different computer, same problem, tried using the mobile phone to do the attack, same problem. I discovered the only attack I could do was a nuclear one, so I did that. after 12 maps I attempted another nuclear attack and the problem popped up again. I eventually traced the probelm to the names in some of the nation's cities. some were named City xx, and come were named Cítч xx. the ones named Cítч xx I couldnt even nuke, the ones named City xx I could, so I determined that the use of the odd characters in the cities named Cítч were the problem and not on my end.

Link to page: nation with the odd city names https://test.politicsandwar.com/nation/id=196908

Any other relevant information: After discovering this bug I thought, wow, if this bug existed on live, it could make a nation invincible, they could attack anyone they wanted and no one could attack them back.... this is a MAJOR game breaker IMO. I have not tested it on live as to do so even as a test could be seen as exploiting a bug. so I hand this off to you

 

Screenshot: (if available)

Clipboard.png

  • Upvote 2
Link to post
Share on other sites
  • Administrators

I updating the encoding on that table in the database, will you let me know if you're still having the issue now please?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and the Guidelines of the game and community.